Cisco Secure Firewall Adaptive Security Appliance (ASA) Software: Unchecked Return Value to NULL Pointer Dereference (CVE-2026-76418)
Published Last modified In CISA KEV since Sources: BSI
- Actively exploited
- Source: VulnCheck KEV (opens in a new tab), HKCERT, pwn.watch How we classify
What is affected, what to do
A vulnerability in the Remote Access SSL VPN service of Cisco Secure Firewall Adaptive Security Appliance (ASA) Software and Cisco Secure Firewall Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to reload unexpectedly, resulting in a denial of service (DoS) condition. This vulnerability is due to logic errors when secondary authentication is configured on a tunnel group.
The vulnerability is being actively exploited; treat it as a priority. Update secure_firewall_threat_defense to version 10.0.3, ASA (Adaptive Security Appliance) to version 9.16.4.104, Secure Firewall Threat Defense to version 10.0.3. Immediate actions, mitigation and detection rules are in the runbook below.
- Affected
- Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.1..9.16.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.1.28..9.16.1.28 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2..9.16.2 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2.3..9.16.2.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2.7..9.16.2.7 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2.11..9.16.2.11 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2.13..9.16.2.13 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.2.14..9.16.2.14 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3.3..9.16.3.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3..9.16.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3.14..9.16.3.14 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.1..9.18.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3.15..9.16.3.15 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.1.3..9.18.1.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.2..9.18.2 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3.19..9.16.3.19 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.3.23..9.16.3.23 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.2.5..9.18.2.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4..9.16.4 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.2.7..9.18.2.7 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1..9.19.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.9..9.16.4.9 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.2.8..9.18.2.8 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.14..9.16.4.14 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3..9.18.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.5..9.19.1.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.18..9.16.4.18 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.9..9.19.1.9 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3.39..9.18.3.39 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.19..9.16.4.19 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.12..9.19.1.12 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3.46..9.18.3.46 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.27..9.16.4.27 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.18..9.19.1.18 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3.53..9.18.3.53 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3.55..9.18.3.55 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.38..9.16.4.38 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.39..9.16.4.39 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.3.56..9.18.3.56 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.1..9.20.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.42..9.16.4.42 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.22..9.19.1.22 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4..9.18.4 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.1.5..9.20.1.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.5..9.18.4.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.24..9.19.1.24 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.48..9.16.4.48 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.8..9.18.4.8 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.2..9.20.2 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.27..9.19.1.27 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.55..9.16.4.55 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.22..9.18.4.22 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.2.10..9.20.2.10 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.57..9.16.4.57 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.28..9.19.1.28 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.24..9.18.4.24 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.2.21..9.20.2.21 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.61..9.16.4.61 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.31..9.19.1.31 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.29..9.18.4.29 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.2.22..9.20.2.22 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.62..9.16.4.62 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.34..9.18.4.34 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3..9.20.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.67..9.16.4.67 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.70..9.16.4.70 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.40..9.18.4.40 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1..9.23.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.1.1..9.22.1.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.71..9.16.4.71 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.4..9.20.3.4 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.47..9.18.4.47 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.7..9.20.3.7 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.37..9.19.1.37 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.76..9.16.4.76 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.9..9.20.3.9 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.38..9.19.1.38 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.50..9.18.4.50 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.1.3..9.22.1.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.10..9.20.3.10 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.1.2..9.22.1.2 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.52..9.18.4.52 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.13..9.20.3.13 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.1.6..9.22.1.6 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.53..9.18.4.53 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.82..9.16.4.82 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2..9.22.2 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.16..9.20.3.16 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.19.1.42..9.19.1.42 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.57..9.18.4.57 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.84..9.16.4.84 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.3..9.23.1.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.3.20..9.20.3.20 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.4..9.22.2.4 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.7..9.23.1.7 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4..9.20.4 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.9..9.22.2.9 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.13..9.23.1.13 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.7..9.20.4.7 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.13..9.22.2.13 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.66..9.18.4.66 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.10..9.20.4.10 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.19..9.23.1.19 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.85..9.16.4.85 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.14..9.22.2.14 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.67..9.18.4.67 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1..9.24.1 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.68..9.18.4.68 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.22..9.23.1.22 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.14..9.20.4.14 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.20..9.22.2.20 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.71..9.18.4.71 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.19..9.20.4.19 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.26..9.23.1.26 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.89..9.16.4.89 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.2.32..9.22.2.32 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.76..9.18.4.76 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.3..9.22.3 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1.5..9.24.1.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.22..9.20.4.22 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1.9..9.24.1.9 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.28..9.20.4.28 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.3.5..9.22.3.5 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.92..9.16.4.92 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.135..9.18.4.135 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.195..9.23.1.195 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.30..9.20.4.30 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1.155..9.24.1.155 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.32..9.23.1.32 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1.11..9.24.1.11 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.34..9.20.4.34 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.82..9.18.4.82 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.10..9.24.10 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.90..9.18.4.90 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.46..9.20.4.46 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.235..9.20.4.235 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.20.4.49..9.20.4.49 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.22.3.26..9.22.3.26 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.16.4.103..9.16.4.103 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.18.4.94..9.18.4.94 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.23.1.47..9.23.1.47 - Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
eq 9.24.1.26..9.24.1.26 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.0..7.0.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.0.1..7.0.0.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.1..7.0.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.1.1..7.0.1.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.2..7.0.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.0..7.2.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.2.1..7.0.2.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.3..7.0.3 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.0.1..7.2.0.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.4..7.0.4 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.1..7.2.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.5..7.0.5 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.3.0..7.3.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.2..7.2.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.3..7.2.3 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.3.1..7.3.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.4..7.2.4 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.6..7.0.6 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.5..7.2.5 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.4.1..7.2.4.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.3.1.1..7.3.1.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.0..7.4.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.6.1..7.0.6.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.5.1..7.2.5.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.1..7.4.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.6..7.2.6 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.6.2..7.0.6.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.1.1..7.4.1.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.7..7.2.7 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.5.2..7.2.5.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.3.1.2..7.3.1.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.8..7.2.8 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.0..7.6.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.2..7.4.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.8.1..7.2.8.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.6.3..7.0.6.3 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.2.1..7.4.2.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.9..7.2.9 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.7..7.0.7 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.7.0..7.7.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.2.2..7.4.2.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.10..7.2.10 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.1..7.6.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.2.3..7.4.2.3 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.8..7.0.8 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.2..7.6.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.7.10..7.7.10 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.7.11..7.7.11 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.8.1..7.0.8.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.2.1..7.6.2.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.7.10.1..7.7.10.1 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.2.4..7.4.2.4 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.10.2..7.2.10.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.3..7.4.3 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.4..7.6.4 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 10.0.0..10.0.0 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.4..7.4.4 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.9..7.0.9 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.11..7.2.11 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.7..7.4.7 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.4.8..7.4.8 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.2.12..7.2.12 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.6.6..7.6.6 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.7.13..7.7.13 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 10.0.2..10.0.2 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 7.0.10..7.0.10 - Cisco Secure Firewall Threat Defense (FTD) Software
eq 10.1.0..10.1.0
- Cisco Secure Firewall Adaptive Security Appliance (ASA) Software
Not sure whether and how you are affected? Ask a question about this vulnerability
Metrics
8.6
Priority
XIEM Effective CVSS: highest available CVSS rating from NVD and vendor data.
Source: NVD, CVSS v3
8.6
CVSS v3
Severity High on the scale from 0 to 10.
Source: BSI
0.6 %
EPSS score
Low — model estimates < 1% exploitation likelihood.
Source: FIRST EPSS, percentile 47.3
Show all metrics
- Severity
- Critical
Priority (0–325)
The priority score is a consolidated metric that condenses several individual signals into a single, action-guiding ranking: technical severity (CVSS), exploitation likelihood (EPSS), known-exploited status (KEV) and the context of the affected asset. The aim is to answer the only truly important question in vulnerability management: what first?
Read in glossary- 190.91 Methodology
Exploit maturity
An exploit is code or a technique that specifically uses a concrete vulnerability to force unintended behaviour — such as executing code or escalating privileges. It is the tool that turns a theoretical flaw into a practical attack.
Read in glossary- actively exploitedSource: VulnCheck KEV (opens in a new tab), HKCERT, pwn.watch How we classify
XIEM Effective CVSS
XIEM® is the tiered managed-security operating model from NEOSEC and a registered trademark of NEOSEC GmbH. It extends classic SIEM — the central collection, normalisation and correlation of security-relevant events — with endpoint forensics, network visibility and deception technology, and consolidates them into three building tiers: Sentry, Orchestrate and Command.
Read in glossary- 8.6 Methodology
CVSS v3
CVSS is the globally established, open standard for assessing the technical severity of a vulnerability on a scale from 0 to 10. It describes how easily a flaw can be exploited and what damage it can cause — but not how likely its actual exploitation is. CVSS and the complementary EPSS deliberately answer different questions.
Read in glossary- 8.6
EPSS score
The EPSS score is the absolute model output for an individual vulnerability: the estimated probability of real-world exploitation within the next 30 days, expressed as a value between 0 and 1 (i.e. 0 % to 100 %). A score of 0.42 means „the model estimates a 42 % chance of real-world exploitation within 30 days“.
Read in glossary- 0.6 %
- Low — model estimates < 1% exploitation likelihood.
EPSS percentile
The EPSS percentile is the relative position of a vulnerability within all EPSS-scored CVEs, expressed as a value between 0 and 1. A percentile of 0.90 means „this CVE has a higher EPSS score than 90 % of all other scored CVEs“. Unlike the EPSS score, it is not a probability — but a positioning within a ranking.
Read in glossary- 47.3
- High — this CVE ranks above the median of all CVEs scored today (rank ≥ 36%).
KEV status
The KEV catalogue is a list maintained by the US authority CISA of vulnerabilities for which active exploitation in the wild has been confirmed. It answers not the question „how severe?“ but „is it already being attacked?“ — thereby sharply prioritising patching.
Read in glossary- Actively exploited
- Published
In CISA KEV since
The KEV catalogue is a list maintained by the US authority CISA of vulnerabilities for which active exploitation in the wild has been confirmed. It answers not the question „how severe?“ but „is it already being attacked?“ — thereby sharply prioritising patching.
Read in glossary- CISA assessment (SSVC)
- Exploitation: active · automatable · Technical impact: partial
- Source: CISA Vulnrichment, as of 28 October 2026
CWE
CWE is a catalogue of typical weakness types in software and hardware — such as flawed input validation, unsafe memory handling or poor authentication. Where a CVE names a concrete vulnerability in a concrete product, a CWE describes the underlying class of defect.
Read in glossary- CWE-690
Response and mitigation
Why act now?
Prioritisation rationale
This is a network-reachable flaw that needs no authentication or user interaction and sits on a perimeter device. Its impact is availability-only, but the changed scope means the entire appliance reloads, not just the VPN service. Cisco edge VPN gateways are attractive targets because a cheap, repeatable crash disrupts both remote access and perimeter enforcement for a whole organisation. Repeated reloads can also mask other activity or expose weak failover designs. CISA does not flag ransomware use. For KRITIS and NIS2 entities running internet-facing SSL VPN with secondary authentication, treat remediation as critical within 24-72 h. Without Remote Access VPN enabled, or without secondary authentication configured, handling it in the regular patch cycle is defensible.
Runbook step 1
Immediate response (0-24 h)
- Inventory exposure: Identify every ASA and FTD instance running Remote Access SSL VPN (Cisco Secure Client/AnyConnect, TCP 443 plus DTLS on UDP 443). Run
show versionto check the release. Affected per context: ASA 9.16.1, 9.16.1.28, 9.16.2, 9.16.2.3, 9.16.2.7, 9.16.2.11, 9.16.2.13 and 9.16.2.14. FTD is also affected according to the description; check the Cisco Security Advisory for the exact FTD releases. - Find the triggering configuration: Exploitation requires secondary authentication on a tunnel group. Locate it with
show running-config tunnel-group | include secondary-authentication-server-group. Internet-facing boxes with this setting go to the top of the queue. - Patch: A patch is available from the vendor; look up the fixed version in the vendor advisory. Use the Cisco Software Checker to determine the first fixed release for your 9.16.x or FTD train. For Active/Standby pairs, upgrade the standby unit first, then fail over.
- Preserve crash evidence before rebooting: Collect
show crashinfoandshow tech-support(for FTD, a troubleshoot file via FMC/FDM) to see whether unexplained reloads have already occurred. Keep the artefacts for forensics and any NIS2 incident notification. - Plan for continuity: A successful attack reloads the whole firewall node, not just the VPN service. Alert business-continuity owners, schedule maintenance windows and verify out-of-band management access.
- Inventory exposure: Identify every ASA and FTD instance running Remote Access SSL VPN (Cisco Secure Client/AnyConnect, TCP 443 plus DTLS on UDP 443). Run
Runbook step 2
Mitigation layers
- Configuration change (temporary): If you cannot patch now, remove secondary authentication from exposed tunnel groups or move users to a group without
secondary-authentication-server-group. If that secondary step is your second factor, enforce MFA another way, such as RADIUS/SAML MFA on the primary authentication. Record the trade-off in the risk register. - Network restriction: Limit who can reach the VPN listener (TCP/UDP 443 on outside). Use a control-plane ACL (
access-group ... in interface outside control-plane) or an upstream router filter, with geo-blocking or partner allowlists where feasible. - On-box abuse throttling: Where your release supports it, enable
threat-detection service remote-access-authenticationandthreat-detection service remote-access-client-initiationsto shun sources that hammer the VPN portal. - Upstream IPS/DDoS layer: Rate-limit new TLS sessions to the VPN headend IP. Enable Cisco Talos Snort signatures for this CVE on an upstream IPS once published, because the vulnerable device cannot be relied on to protect itself.
- Redundancy: Single-box sites should stage a fallback VPN headend on a different software level or product, so a forced reload does not take remote access down entirely.
- Configuration change (temporary): If you cannot patch now, remove secondary authentication from exposed tunnel groups or move users to a group without
Runbook step 3
Detection rules
- Unexpected reloads (syslog): Alert on boot messages that have no matching admin
reload:%ASA-5-199005(Startup begin) and%ASA-6-199002(Startup completed). KQL:CommonSecurityLog | where DeviceVendor == "Cisco" and DeviceEventClassID in ("199005","199002"). Correlate the results against change tickets. - SNMP/monitoring: Treat
coldStart/warmStarttraps or asysUpTimereset on the firewall as an incident. For HA pairs, also watch for unplanned failover events (syslog 104001/104002). - Crash files: Poll
show crashinfo(via Ansible/EEM) for new entries. A traceback referencing WebVPN/SSL VPN processes is a strong exploitation indicator. - Suspicious VPN traffic: In WebVPN (716xxx), SVC (722xxx) and AAA (113xxx) syslogs, look for bursts of connection attempts against tunnel groups with secondary authentication, especially from a single external IP shortly before a reload. In Zeek/Suricata, flag spikes in new TLS sessions to the headend and requests to
/+CSCOE+/or/+webvpn+/from previously unseen sources. - Sigma shape:
logsource: product: cisco, service: asa·selection: message|contains: '199005'·filter: preceding '111008'/'111010' (admin command) within 10 min·condition: selection and not filter.
- Unexpected reloads (syslog): Alert on boot messages that have no matching admin
Detection rules
No NEOSEC detection rule is available for this vulnerability yet.
Classification under NIS2 and CRA
Rule-based classification from exploitation status and severity. It does not replace a case-by-case assessment.
NIS2
NIS2 is EU Directive (EU) 2022/2555 to raise the level of cybersecurity across the Union. It substantially broadens obligations compared with the first NIS directive: more sectors, mandatory risk management, staged reporting duties and personal accountability of senior management.
Read in glossary- Actively exploited: treat the vulnerability as a priority in vulnerability handling under Art. 21(2)(e) NIS2. If it is exploited in your environment, check the reporting obligation under Art. 23 (early warning within 24 hours).
CRA
The CRA is EU Regulation (EU) 2024/2847 setting horizontal cybersecurity requirements for „products with digital elements“ — from industrial controllers and software to connected consumer devices. For the first time manufacturers must ensure security across the entire product lifecycle, handle vulnerabilities and provide security updates.
Read in glossary- Since 11.09.2026, manufacturers of affected products with digital elements must report actively exploited vulnerabilities under Art. 14 CRA, with an early warning within 24 hours via ENISA's single reporting platform.
ISO/IEC 27001
ISO/IEC 27001 is the internationally leading standard for an information security management system (ISMS). It describes a risk-based, process-oriented framework to systematically plan, implement, review and improve information security.
Read in glossary- Control A.8.8, management of technical vulnerabilities: assess relevance to your systems, plan remediation and keep evidence.
Description
A vulnerability in the Remote Access SSL VPN service of Cisco Secure Firewall Adaptive Security Appliance (ASA) Software and Cisco Secure Firewall Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to reload unexpectedly, resulting in a denial of service (DoS) condition. This vulnerability is due to logic errors when secondary authentication is configured on a tunnel group. An attacker could exploit this vulnerability by sending a crafted request when connecting to the SSL remote access VPN. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition.
Source: BSI WID Portal
Affected products
The following versions are affected. Older releases of the same product line are also vulnerable unless stated otherwise.
| Affected versions | Fixed in | ||
|---|---|---|---|
| Cisco | Cisco Secure Firewall Adaptive Security Appliance (ASA) Software |
|
|
From bundled advisories, not CVE-specific (2)
Product list of a bundled advisory that does not state which product this CVE affects.
| Affected versions | Fixed in | ||
|---|---|---|---|
| cisco | cisco asa |
|
|
Vendors and products
Affected operating systems
| Other | cisco | adaptive_security_appliance_software | — |
| Other | cisco | adaptive_security_appliance_software | 9.24.10 |
Weakness classes (CWE)
CWE-690Unchecked Return Value to NULL Pointer Dereference
Compound
The product does not check for an error after calling a function that can return with a NULL pointer if the function fails, which leads to a resultant NULL pointer dereference.
Entry at MITRE CWE-690
Public exploit references
Publicly reported proof-of-concepts, exploit modules and detection templates for this vulnerability. NEOSEC links to the original sources only and does not provide any exploit code.
| CISA KEV Catalog | CISA Known Exploited Vulnerability (opens in a new tab)cisa.gov | actively exploited | |
| HKCERT | Cisco Products Denial of Service Vulnerability (opens in a new tab)HKCERT | actively exploited |
References & sources
- sec.cloudapps.cisco.comcisco-sa-asaftd-tunnel-dos-s6mgkb75pwn-watch, Vendor advisory
- pwn.watchpwn.watch: Cisco ASA and FTD zero-day CVE-2026-76418 exploited to crash SSL VPN firewallspwn-watch
- NVD (NIST)NVD: CVE-2026-76418pwn-watch
- bleepingcomputer.comNew Cisco firewall zero-day exploited to crash SSL VPN devicespwn-watch
- thehackernews.comCisco Patches Actively Exploited ASA and FTD VPN Flaw That Can Crash Firewallspwn-watch
- cisa.govknown-exploited-vulnerabilities-catalog?field_cve=CVE-2026-76418government-resource, US government resource
Changes to this CVE
Who changed this CVE and when: NVD (analysis, affected products, CVSS), the CVE publisher (CNA) and additional providers such as CISA (ADP).
Initial analysis by NVDNVD
Newly listed as affected:- Cisco Adaptive Security Appliance (ASA) Software (before 9.16.4.104; 9.18 – before 9.18.4.96; 9.22 – before 9.22.3.200; 9.23 – before 9.23.1.48; 9.24.1 – before 9.24.1.27; 9.19 – before 9.20.4.50; 1 individual version)
- Cisco Firepower Threat Defense Software (before 7.0.11; 10.0.0 – before 10.0.3; 7.2.0 – before 7.2.13; 7.6.0 – through 7.6.7; 7.7.0 – before 7.7.14; 7.3.0 – before 7.4.9; 1 individual version)
Show 4 original changes
Individual changes of this event as published by NVD Type Action Before After Product configuration added —OR *cpe:2.3:o:cisco:adaptive_security_appliance_software:9.24.10:*:*:*:*:*:*:* *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions up to (excluding) 9.16.4.104 *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions from (including) 9.18 up to (excluding) 9.18.4.96 *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions from (including) 9.22 up to (excluding) 9.22.3.200 *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions from (including) 9.23 up to (excluding) 9.23.1.48 *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions from (including) 9.24.1 up to (excluding) 9.24.1.27 *cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* versions from (including) 9.19 up to (excluding) 9.20.4.50Product configuration added —OR *cpe:2.3:a:cisco:secure_firewall_threat_defense:10.1.0:*:*:*:*:*:*:* *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions up to (excluding) 7.0.11 *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions from (including) 10.0.0 up to (excluding) 10.0.3 *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions from (including) 7.2.0 up to (excluding) 7.2.13 *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions from (including) 7.6.0 up to (including) 7.6.7 *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions from (including) 7.7.0 up to (excluding) 7.7.14 *cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* versions from (including) 7.3.0 up to (excluding) 7.4.9Reference type added —Cisco Systems, Inc.: https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-tunnel-dos-s6mgkb75 Types: Vendor AdvisoryReference type added —CISA-ADP: https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-76418 Types: US Government ResourceSource identifier: nvd@nist.gov
Record modifiedCISA ADP
CISA assessment (SSVC): exploitation: active, automatable: yes
Show 2 original changes
Individual changes of this event as published by NVD Type Action Before After SSVC assessment removed {"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"active"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-29T19:50:11.066278Z"}—SSVC assessment added —{"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"active"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-28T00:00:00+00:00"}Source identifier: 134c704f-9b21-4f2e-91b3-4a467353bcc0
CISA KEV entry updated9119a7d8…
4 individual changes: Date Added, Due Date, Required Action, Vulnerability Name
Show 4 original changes
Individual changes of this event as published by NVD Type Action Before After Date Added added —2026-10-29Due Date added —2026-10-29Required Action added —2026-10-29Vulnerability Name added —2026-10-29Source identifier: 9119a7d8-5eab-497f-8521-727c672e3725
Record modifiedCISA ADP
CISA assessment (SSVC): exploitation: active, automatable: yes
Show 3 original changes
Individual changes of this event as published by NVD Type Action Before After Reference added —https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-76418SSVC assessment removed {"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"none"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-28T00:00:00+00:00"}—SSVC assessment added —{"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"active"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-29T19:50:11.066278Z"}Source identifier: 134c704f-9b21-4f2e-91b3-4a467353bcc0
Record modifiedCISA ADP
CISA assessment (SSVC): exploitation: none known, automatable: yes
Show 2 original changes
Individual changes of this event as published by NVD Type Action Before After SSVC assessment removed {"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"none"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-28T22:45:52.484574Z"}—SSVC assessment added —{"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"none"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-28T00:00:00+00:00"}Source identifier: 134c704f-9b21-4f2e-91b3-4a467353bcc0
Show 2 older changes
Record modifiedCISA ADP
CISA assessment (SSVC): exploitation: none known, automatable: yes
Show the original change
Individual changes of this event as published by NVD Type Action Before After SSVC assessment added —{"id":"CVE-2026-76418","role":"CISA Coordinator","options":[{"exploitation":"none"},{"automatable":"yes"},{"technicalImpact":"partial"}],"version":"2.0.3","timestamp":"2026-10-28T22:45:52.484574Z"}Source identifier: 134c704f-9b21-4f2e-91b3-4a467353bcc0
ReceivedCisco
CVSS V3.1: AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness type: CWE-690
Description added or changed
Show 5 original changes
Individual changes of this event as published by NVD Type Action Before After Description added —A vulnerability in the Remote Access SSL VPN service of Cisco Secure Firewall Adaptive Security Appliance (ASA) Software and Cisco Secure Firewall Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to reload unexpectedly, resulting in a denial of service (DoS) condition. This vulnerability is due to logic errors when secondary authentication is configured on a tunnel group. An attacker could exploit this vulnerability by sending a crafted request when connecting to the SSL remote access VPN. A successful exploit could allow the attacker to cause the affected device to reload, resulting in a DoS condition.CVSS added —AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:HWeakness type (CWE) added —CWE-690Affected versions (publisher) added —New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/76xxx/CVE-2026-76418.json">CVE-2026-76418</a>Reference added —https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-tunnel-dos-s6mgkb75Source identifier: psirt@cisco.com
Linked CVEs
| Critical | CVE-2026-76418 | Cisco Secure Firewall Threat Defense (FTD) Software: Unchecked Return Value to NULL Pointer Dereference | 8.6 | Actively exploited |
Linked advisories
- NCSC-2026-0463 [1.00] [M/H] Kwetsbaarheid verholpen in Cisco Secure Firewall ASA en FTD SoftwareNCSC-NL
- New Cisco firewall zero-day being actively exploitedCSO Online
- Cisco Patches Actively Exploited ASA and FTD VPN Flaw That Can Crash FirewallsThe Hacker News
- Attackers Exploit Second Cisco Firewall VPN Zero-Day Since AugustSecurityWeek
- Vulnérabilité dans les produits Cisco (29 octobre 2026)CERT-FR (ANSSI)
- Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense Software Remote Access SSL VPN Tunnel Denial of Service VulnerabilityCisco PSIRT
Embed badge
Show the severity and KEV status of this vulnerability on your site – with a link back here. The image is updated hourly.
<a href="https://intel.neosec.eu/en/cve/CVE-2026-76418"><img src="https://intel.neosec.eu/badge/cve/CVE-2026-76418.svg?lang=en" alt="CVE-2026-76418 – NEOSEC Intel" height="20"></a>